Download: GIMP 2.9.x (Mac OS X)


Warning: Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /home/rabatmal/public_html/websites/evolve.rabatmalta.com/wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524

These builds are of the development branch of the GIMP. They may be very unstable, and as such should not be used in production.

Bookmark the permalink.

Comments are closed.